Тема. Робота з текстом в Macromedia Flash 
1. Створення статичного тексту
2. Розширюваний горизонтальний текст
3. Статичний горизонтальний текст заданої ширини
4. Статичний вертикальний текст
5. Функція Аlias Тext
6. Використання device-шрифтів (тільки для горизонтального тексту) форматування тексту
7. Установка вирівнювання, полів, абзаців і міжрядкового інтервалу
8. Налаштування режиму, при якому користувачеві дозволено виділення тексту (тільки для горизонтального тексту)
9. Редагування тексту
10. Зв'язування тексту з URL
11. Перетворення і розбиття тексту

Додавати текст в Macromedia Flash MX 2004 і Macromedia Flash MX Professional 2004 можна декількома способами. Ви можете створити текстові блоки, що містять статичний текст (static text) - текст, зміст і зовнішній вигляд якого ви визначаєте, коли створюєте документ. Ви також можете створити динамічний текст (dynamic text) - текст, динамічно змінюється під час відтворення ролика, наприклад такий текст може відображати рахунок в грі або біржові зведення.
Можна також створити текст для поля введення Input Text Fields. Поле введення дозволяє користувачам вводити текст в інтерактивні форми. За допомогою подібного поля користувач може передати інформацію на сервер. Поля текстового введення дозволяють вводити текст у форми, звіти і т.д. В даному уроці мова піде тільки про статичних текстах, про динамічному тексті і тексті для полів вводу ми поговоримо в інших уроках.
Статичний текст можна орієнтувати не тільки горизонтально (зліва направо), але і вертикально (як зліва направо, так і справа наліво). Flash MX дозволяє застосовувати всі основні елементи форматування (змінювати шрифт, розмір тексту, стиль, колір, трекінг, кернінг, зрушення базової лінії, вирівнювання, поля, відступи і т.д.). Текст можна змінювати так само, як звичайний об'єкт, - повертати, масштабувати, застосовувати до нього деформацію зсуву, робити дзеркальне відображення тексту і т.д., і при цьому у вас залишиться можливість редагувати його як текст. Горизонтальним текстових блоків можна давати посилання на заданий URL. Текст можна перевести в графічне представлення і потім застосовувати до букв (як до графічних об'єктів) всі види графічних перетворень. Отже, розглянемо ці можливості по порядку.
1. [bookmark: 01]Створення статичного тексту
Для створення тексту виберіть інструмент Text (кнопка з літерою А - вона показана такою, що натискує на рис. 1) і виконайте команду Window => Properties. В результаті з'явиться однойменна панель.
[image: https://compress.ru/archive/cp/2004/2/13/image001.jpg]
Мал. 1. Інструмент Text і панель Properties
У лівій частині панелі Properties знаходиться меню, що випадає (на рис. 1 воно виділено світлим еліпсом), в якому можна вибрати тип текстового поля: Static Text (Статичний текст), Dynamic Text (Динамічний текст) або Input Text (Поле введення).
Виберіть варіант Static text. Програма Flash дозволяє створювати різні види статичних текстових полів, розглянемо їх послідовно.

2. [bookmark: 02]Розширюваний горизонтальний текст
Для створення росширюваного горизонтального тексту виберіть інструмент Тext, клацніть на робочому полі (з'явиться текстовий блок, в правому верхньому кутку якого є круглий маркер), зі зворотним відліком блок розширюється (рис. 2).
[image: https://compress.ru/archive/cp/2004/2/13/2.jpg]
Мал. 2. Горизонтальний текст, розширюваний під час введення

3. [bookmark: 03]Статичний горизонтальний текст заданої ширини
Для створення статичного горизонтального тексту заданої ширини виберіть інструмент Тext, клацніть і, утримуючи ліву кнопку, перетягніть курсор для завдання потрібної ширини текстового блоку. У правому верхньому кутку текстового блоку розташовується квадратний маркер. Текстовий блок має фіксовану довжину. Текст вирівнюється під цю довжину шляхом автоматичного перенесення (рис. 3).
[image: https://compress.ru/archive/cp/2004/2/13/3.jpg]
Мал. 3. Статичний горизонтальний текст заданої ширини
Якщо ви хочете поміняти ширину текстового блоку, потягніть за маркер - перенесення слів в тексті і висота текстового блоку поміняються автоматично (рис. 4).
[image: https://compress.ru/archive/cp/2004/2/13/4.jpg]
Мал. 4. При зміні ширини текстового блоку відбувається автоматичний перенос слів


4. [bookmark: 04]Статичний вертикальний текст
Для того щоб мати у своєму розпорядженні текст вертикально, натисніть на її зображення з буквами Abcd (рис. 5). В результаті з'явиться панель, де можна вибрати варіанти Vertical, Left to Right (при цьому текст буде заповнюватися, як показано на рис. 5) або Vertical, Right to left (в цьому випадку текст буде заповнюватися вертикально справа наліво).
[image: https://compress.ru/archive/cp/2004/2/13/5.jpg]
Мал. 5. Приклад вертикального текстового блоку

5. [bookmark: 05]Функція Аlias Тext
Кнопка Alias ​​Text (на рис. 6 вона виділена світлим еліпсом) дозволяє більш чітко відображати текст при малих розмірах шрифту. Для того щоб зрозуміти, як працює ця функція, зробіть два написи, наприклад, шрифтом Times New Roman 8 пунктів, причому одну якщо ввімкнено Alias ​​Text, а іншу, скасувавши цю функцію (кнопка Аlias Тext виділена світлим еліпсом на рис. 6).
[image: https://compress.ru/archive/cp/2004/2/13/6.jpg]
Мал. 6. Застосування функції Аlias Тext
Потім виконайте команду Control => Test Scene, і ви побачите результат, показаний на рис. 7. Як видно з рис. 7, написи сильно розрізняються за якістю.
[image: https://compress.ru/archive/cp/2004/2/13/7.jpg]
Мал. 7. Приклад відображення написів із застосуванням функції Аlias Тext і без неї
[bookmark: 06]
6. Використання device-шрифтів (тільки для горизонтального тексту)
За замовчуванням шрифти вбудовуються в результуючий файл Flash-ролика. Коли ви створюєте статичний текст, то можете вказати, щоб Flash Player застосовував device-шрифти для відображення певних текстових блоків. Використання device-шрифтів дозволяє зменшити розмір результуючого файлу вашого документа, оскільки документ не містить зайвої інформації про даний шрифті. Застосування device-шрифтів дозволяє також збільшити чіткість тексту при розмірах менше 10 пунктів. Для того щоб визначити, що текст повинен відображатися з використанням device-шрифтів, необхідно виділити текстовий блок, в панелі Properties вибрати режим Static Text і поставити прапорець Use Device Fonts (на рис. 8 він виділений світлим еліпсом).
[image: https://compress.ru/archive/cp/2004/2/13/8.jpg]
Мал. 8. Використання device-шрифтів
7. [bookmark: 07]Форматування тексту
При виборі шрифту з меню, що випадає (рис. 9) в панелі праворуч відображається його накреслення. Поруч з панеллю вибору шрифту розташовуються кнопки, які дозволяють задати розмір шрифту, зробити текст напівжирним або курсивним і вибрати колір заливки тексту. Інтерфейс даних кнопок реалізований так само, як і в програмі Word, і не вимагає пояснень.
[image: https://compress.ru/archive/cp/2004/2/13/9.jpg]
Мал. 9. Вибір шрифту
Для того щоб змінити міжсимвольний інтервал, клацніть по стрілці вниз поруч з полем Character Spacing (рис. 10) і пересуньте движок або просто введіть потрібне значення в поле введення.
[image: https://compress.ru/archive/cp/2004/2/13/10.jpg]
Мал. 10. Приклад зміни міжсимвольного інтервалу
Щоб розмістити текст вище або нижче базової лінії, клацніть по стрілці вниз поруч з полем Character Position (рис. 10) і виберіть потрібне розміщення з меню: варіант Normal - розміщення тексту по базовій лінії, Superscript - текст знаходиться вище базової лінії (для горизонтального тексту ) або правіше її (для вертикального тексту), Subscript - текст розташовується в нижній частині бази лінією (для горизонтального тексту) або лівіше її (для вертикального тексту).
[image: https://compress.ru/archive/cp/2004/2/13/11.jpg]
Мал. 11. Зміщення тексту від базової лінії в верхній і нижній регістри
Текст зверху надруковано в режимі Subscript, а нижній в режимі Superscript
[bookmark: 08]Установка вирівнювання, полів, абзаців і міжрядкового інтервалу
Іконки вирівнювання тексту по лівому краю, по центру і по правому краю виглядають так само, як і в програмі Word, а тому їх призначення вам буде зрозуміло.
Для того щоб налаштувати параметри Indent (Відступ), Line Spacing (міжрядковий відстань), Left Margin (Ліве поле) і Right Margin (Правое поле), клацніть по кнопці Format Options і встановіть потрібні значення у відповідних полях (рис. 12).
[image: https://compress.ru/archive/cp/2004/2/13/12.jpg]
Мал. 12. Панель настройки відступу, міжрядкового відстані, лівого і правого полів
8. [bookmark: 09]Налаштування режиму, при якому користувачеві дозволено виділення тексту (тільки для горизонтального тексту)
Для того щоб дозволити користувачеві виділяти текст в результуючому документі, виділіть горизонтальний текст, виберіть режим Static Text, встановіть прапорець Use Device Fonts (Використовувати device-шрифти) і клацніть по кнопці Selectable (на рис. 13 вона виділена світлим еліпсом). Виконавши команду Control => Test Scene, можна переконатися, що текст в результуючому документі дійсно можна виділяти.
[image: https://compress.ru/archive/cp/2004/2/13/13.jpg]
Мал. 13. Кнопка Selectable (виділена світлим еліпсом)
[bookmark: 10]
9. Редагування тексту
При редагуванні тексту в Flash можна користуватися тими ж прийомами, що і при роботі в більшості текстових редакторів. Можна використовувати команди Cut, Copy і Paste як для переміщення тексту всередині програми Flash, так і для обміну текстом з іншими додатками. Щоб виділити текстовий блок, виберіть інструмент Arrow і клацніть по текстовому блоку. Для одночасного виділення декількох блоків, клацайте по ним, утримуючи клавішу Shift (рис. 14).
[image: https://compress.ru/archive/cp/2004/2/13/14.jpg]
Мал. 14. Виділення текстових блоків
10. [bookmark: 11]Зв'язування тексту з URL
Відразу відзначимо, що зв'язування тексту з URL можливо тільки для горизонтального тексту. Надрукуйте текст, наприклад «зв'язування тексту з URL», як на рис. 15. Виділіть надрукований текст і в поле посилання наберіть URL-посилання в нашому прикладі http://www.hownetworks.boom.ru , а потім виконайте команду Control => Тest Scene і клацніть мишею по напису - завантажиться відповідна Web-сторінка.
[image: https://compress.ru/archive/cp/2004/2/13/15.jpg]
Мал. 15. Зв'язування тексту з URL
[bookmark: 12]
11. Перетворення і розбиття тексту
Текстові блоки можна перетворювати точно так же, як і інші об'єкти, - масштабувати, повертати, спотворювати і дзеркально відображати. При масштабуванні текстового блоку як об'єкта збільшення або зменшення розміру шрифту не відбивається в панелі Properties. Як видно на рис. 16, ми збільшили розмір букв в написи, проте в панелі Properties розмір шрифту в пунктах вказано колишній - 53 пункту.
[image: https://compress.ru/archive/cp/2004/2/13/16.jpg]
Мал. 16. Трансформування текстового блоку
Текст можна розбивати на окремі текстові блоки, а також перетворювати в графіку (тобто перетворювати в лінії і області заливки).
Щоб розбити текст, клацніть інструментом Arrow на текстовому блоці і виконайте команду Modify => Break Apart. В результаті всі символи будуть поміщені в окремі текстові блоки (рис. 17).
[image: https://compress.ru/archive/cp/2004/2/13/17.jpg]
Мал. 17. Текст, розбитий на окремі текстові блоки
Ви можете виділити інструментом Arrow кожен символ і перемістити його.
Однак символи можна як і раніше редагувати як елементи тексту. Наприклад, ви можете виділити інструментом Arrow все символи і змінити гарнітуру або розмір шрифту (рис. 18).
[image: https://compress.ru/archive/cp/2004/2/13/18.jpg]
Мал. 18. Приклад зміни шрифту для всіх текстових блоків
Але якщо повторно виконати команду Modify => Break Apart, то букви перетворяться в лінії і заливки. Після такого перетворення символи можна буде редагувати тільки як графічні об'єкти.
Як і будь-які інші фігури, літери тексту можна групувати або перетворювати в символи і анімувати. Виділивши сукупність графічних об'єктів, до них можна застосувати різні перетворення. Наприклад, функція Modify => Transform => Envelope дозволяє різним чином трансформувати контури, в які вписано текст (рис. 19).
[image: https://compress.ru/archive/cp/2004/2/13/19.jpg]
Мал. 19. Режим трансформування Envelope
Цікавого ефекту можна домогтися за допомогою команди Modify => Shape => Soften Fill Edges (рис. 20). Дані режим дозволяє пом'якшити краю контурів.
[image: https://compress.ru/archive/cp/2004/2/13/20.jpg]
Мал. 20. Режим пом'якшення країв
Нагадаємо, що програма дозволяє використовувати не тільки заливку кольором, але і растрову заливку. На рис. 21 в якості заливки була використана фотографія снігу.
[image: https://compress.ru/archive/cp/2004/2/13/21.jpg]
Мал. 21. Використання растрових зображень для заливки
Слід мати на увазі, що команду Break Apart можна застосовувати тільки до векторних шрифтів (TrueType, PostScript). Bitmap-шрифти просто зникнуть при спробі розбити їх.
Видаливши заливку букв (рис. 21) і затоку растром контур, можна зробити букви прозорими і помістити їх на який-небудь фон (рис. 22).
[image: https://compress.ru/archive/cp/2004/2/13/22.jpg]
Мал. 22. Використання ефекту прозорості букв
І нарешті, можна довільним чином змінювати форму букв за допомогою інструментів Subselect і Arrow (рис. 23). Користуючись даними інструментами, можна намалювати літери химерної форми, яких не знайдеш ні в одному стандартному шрифті.
[image: https://compress.ru/archive/cp/2004/2/13/23.jpg]
Мал. 23. За допомогою інструменту Subselect можна редагувати окремі символи
Таким чином, після тексту в окремі графічні об'єкти, з ними можна виконувати всі ті маніпуляції, які Flash дозволяє виробляти з графічними об'єктами. Сподіваюся, ви переконалися, що Flash надає в цьому плані широкий спектр можливостей. Однак, це ще не все, на що здатна програма Flash, - вона також дозволяє створювати цікаві анімаційні ефекти, про які йтиметься в наступному уроці.
[bookmark: _GoBack]
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